• Don't !!! add the brother QL-500 with the default UI of your Ubuntu Linux 18.04 !!!
    • Use https://localhost:631/ Really! Do this!
    • You absolutely don't have to install the cupswrapper or lpr drivers from support.brother.com. Just use the usually preinstalled and recommended foomatic driver on your Ubuntu 18.04.
    • Remove any other instance of this printer in your configuration and use only the one installed by this.
  • You want to use gLabels for editing your labels. Not LibreOffice. Believe me.
    • Just type sudo apt install glabels and enjoy simplicity.